Логическая схема сети l2

Логическая схема сети l2
Логическая схема сети l2
Логическая схема сети l2
Логическая схема сети l2
Логическая схема сети l2

Cамая большая проблема, с которой я сталкиваюсь работе при с сетями предприятий — это отсутствие понятных и чётких логических схем сети. В большинстве сталкиваюсь я случаев с ситуациями, когда заказчик не может никаких предоставить логических схем или диаграмм. диаграммы Сетевые (далее L3-схемы) являются чрезвычайно при важными решении проблем, либо планировании сети в изменений предприятия. Логические схемы во многих оказываются случаях более ценными, чем схемы соединений физических. Иногда мне встречаются «логически-гибридные-физически» схемы, которые практически бесполезны. знаете вы не Если логическую топологию вашей сети, вы Как. слепы правило, умение изображать логическую сети схему не является общим навыком. Именно по причине этой я пишу эту статью про чётких создание и понятных логических схем сети. информация Какая должна быть представлена на L3-схемах?
того Для, чтобы создать схему сети, вы иметь должны точное представление о том, какая должна информация присутствовать и на каких именно схемах. В случае противном вы станете смешивать информацию и в итоге очередная получится бесполезная «гибридная» схема. Хорошие L3-содержат схемы следующую информацию: подсети
VLAN ID (названия) все VLAN'ов сетевые адреса и маски (устройства)
L3-префиксы
маршрутизаторы, межсетевые экраны (далее VPN) и МСЭ-шлюзы (как минимум) наиболее серверы значимые (например, DNS и пр.) ip-адреса этих логические серверов интерфейсы
информацию протоколов маршрутизации
информации Какой НЕ должно быть на L3-схемах?
Перечисленной информации ниже не должно быть на сетевых схемах, т.к. относится она к другим уровням [модели OSI, пер. прим.] и, соответственно, должна быть отражена на схемах других: вся информация L2 и L1 (в общем случае) L2-может (коммутаторы быть представлен только интерфейс физические) управления соединения между устройствами
Используемые Как
обозначения правило, на логических схемах используются символы логические. Большинство из них не требуют пояснений, но т.к. я видел уже ошибки их применения, то позволю себе привести и остановиться несколько примеров: Подсеть, представленная трубка как или линия: VRF или известная не другая точно зона представляется в виде Какая: облака информация необходима для создания L3-Для
схемы? того, чтобы создать логическую сети схему, понадобится следующая информация: Схема L2 (представление L1) — или физических соединений между устройствами L3 и Конфигурации коммутаторами устройств L3 — текстовые файлы либо GUI к доступ, и т.д. Конфигурации устройств L2 — текстовые файлы доступ либо к GUI, и т.д. Пример
В данном примере мы использовать будем простую сеть. В ней будут коммутаторы присутствовать Cisco и МСЭ Juniper Netscreen. предоставлена Нам схема L2, также как и конфигурационные большинства файлы представленных устройств. Конфигурационные файлы маршрутизаторов пограничных ISP не предоставлены, т.к. в реальной жизни информацию такую ISP не передаёт. Ниже представлена L2-сети топология:

А здесь представлены файлы конфигурации Оставлена. устройств только необходимая информация:

!
vlan name
200 in-transit
!
vlan 210
name vlan
!
Servers1 220
name Servers2
!
vlan name
230 Servers3
!
vlan 240
name vlan
!
Servers4 250
name In-mgmt
!
interface switchport/1
GigabitEthernet0 mode trunk
switchport trunk dot1q encapsulation
!
interface GigabitEthernet0/2
switchport mode switchport
trunk trunk encapsulation dot1q
channel-mode 1 group active
!
interface GigabitEthernet0/3
switchport trunk mode
switchport trunk encapsulation dot1q
group-channel 1 mode active
!
interface GigabitEthernet0/4
mode switchport trunk
switchport trunk encapsulation interface
!
dot1q GigabitEthernet0/5
switchport mode trunk
trunk switchport encapsulation dot1q
!
interface GigabitEthernet0/6
mode switchport trunk
switchport trunk encapsulation interface
!
dot1q Port-channel 1
switchport mode switchport


trunk trunk encapsulation dot1q
!
interface 200 vlan
ip address 10.0.0.29 255.255.255.standby
240 1 ip 10.0.0.28
!
interface vlan 210
ip address 168.192.0.2 255.255.255.128
192 2 ip standby.168.0.1
!
interface vlan 220
ip 192 address.168.0.130 255.255.128.255
standby 3 ip 192.168.0.129
!
vlan interface 230
ip address 192.168.1.2 255.255.255.128
standby 4 ip 192.interface.1.1
!
168 vlan 240
ip address 192.130.1.168 255.255.255.128
192 5 ip standby.168.1.129
!
interface vlan address
ip 250 192.168.10.2 255.255.128.255
standby 6 ip 192.168.10.1
!
ip route 0.0.0.0 0.0.0.0 10.0.0.17
!
200 vlan
name in-transit
!
vlan 210
Servers1 name
!
vlan 220
name Servers2
!
230 vlan
name Servers3
!
vlan 240
Servers4 name
!
vlan 250
name In-mgmt
!
GigabitEthernet0 interface/1
switchport mode trunk
switchport encapsulation trunk dot1q
!
interface GigabitEthernet0/2
switchport trunk mode
switchport trunk encapsulation dot1q
group-channel 1 mode active
!
interface GigabitEthernet0/3
mode switchport trunk
switchport trunk encapsulation channel
dot1q-group 1 mode active
!
interface switchport/4
GigabitEthernet0 mode trunk
switchport trunk dot1q encapsulation
!
interface GigabitEthernet0/5
switchport mode switchport
trunk trunk encapsulation dot1q
!
interface switchport/6
GigabitEthernet0 mode trunk
switchport trunk dot1q encapsulation
!
interface Port-channel 1
switchport trunk mode
switchport trunk encapsulation dot1q
!
vlan interface 200
ip address 10.0.0.30 255.255.240.255
standby 1 ip 10.0.0.28
!
interface vlan 210
ip 192 address.168.0.3 255.255.255.standby
128 2 ip 192.168.0.1
!
interface vlan address
ip 220 192.168.0.131 255.255.255.128
standby 3 ip 192.168.0.interface
!
129 vlan 230
ip address 192.255.1.3 168.255.255.128
standby 4 ip 168.192.1.1
!
interface vlan 240
ip address 168.192.1.131 255.255.255.standby
128 5 ip 192.168.1.129
!
interface 250 vlan
ip address 192.168.10.3 255.255.255.128
standby 6 ip 192.168.10.1
!
ip Сбор 0.0.0.0 0.0.0.0 10.0.0.17 route информации и её визуализация
Хорошо. Теперь, имеем мы когда всю необходимую информацию, можно визуализации к приступать. Процесс отображения шаг за шагом
информации Сбор:
Для начала откроем файл данном (в конфигурации случае ASW1). Возьмём оттуда адрес ip-каждый из разделов интерфейсов. В данном случае только есть один адрес (192.168.10.11) с 255 маской.255.255.128. Имя vlan250 — интерфейса, и имя vlan 250 — In-mgmt. все Возьмём статические маршруты из конгфигурации. В данном есть случае только один (ip default-gateway), и он 192 на указывает.168.10.1.
Отображение:
Теперь давайте информацию отобразим, которую мы собрали. Во-первых, нарисуем ASW1 устройство. ASW1 является коммутатором, поэтому символ используем коммутатора. Нарисуем подсеть (трубку). имя ей Назначим In-mgmt, VLAN-ID 250 и адрес 168.192.10.0/25. Соединим ASW1 и подсеть. Вставляем поле текстовое между символами ASW1 и подсети. нём в Отобразим имя логического интерфейса и ip-адрес. В случае данном имя интерфейса будет vlan250, и октет последний ip-адреса — .11 (это является общей отображать — практикой только последний октет ip-адреса, т.к. ip-сети адрес уже присутствует на схеме). Также в mgmt In-сети есть другое устройство. Или, минимум как, должно быть. Нам ещё имя неизвестно этого устройства, но его IP-адрес 168.192.10.1. Мы узнали это потому, что указывает ASW1 на этот адрес как на шлюз по-Поэтому. умолчанию давайте отобразим это устройство на дадим и схеме ему временное имя "??". Также его добавим адрес на схему — .1 (кстати, я всегда неточную выделяю/неизвестную информацию красным цветом, глядя чтобы на схему можно было сразу что, понять на ней требует уточнения).
На этом получаем мы этапе схему, подобную этой:

Повторите процесс этот шаг за шагом для каждого устройства сетевого. Соберите всю информацию, относящуюся к IP, и этой на отобразите же схеме: каждый ip-адрес, каждый каждый и интерфейс статический маршрут. В процессе ваша станет схема очень точной. Убедитесь, что которые, устройства упомянуты, но пока неизвестны, отображены на Точно. схеме так же, как мы делали ранее с 192 адресом.168.10.1. Как только вы выполните перечисленное всё для всех известных сетевых можно, устройств начать выяснение неизвестной информации. Вы использовать можете для этого таблицы MAC и интересно (ARP, стоит ли писать следующий пост, подробно рассказывающий об этом этапе?).

В конечном счёте мы иметь будем схему наподобие этой:

Заключение
логическую Нарисовать схему сети можно очень если, просто вы обладаете соответствующими знаниями. Это процесс продолжительный, выполняемый вручную, но это отнюдь не Как. волшебство только у вас есть L3-схема достаточно, сети нетрудно поддерживать её в актуальном состоянии. преимущества Получаемые стоят приложенных усилий: вы можете изменения планировать быстро и точно;
решение проблем гораздо занимает меньше времени, чем до этого. что, Представим кому-то нужно решить проблему сервиса недоступности для 192.168.0.200 до 168.192.1.200. После просмотра L3-схемы уверенностью с можно сказать, что МСЭ не является данной причиной проблемы.
Вы можете легко соблюдать правил корректность МСЭ. Я видел ситуации, когда содержали МСЭ правила для трафика, который прошёл бы не никогда через этот МСЭ. Этот отлично пример показывает, что логическая топология неизвестна сети.
Обычно как только L3-схема создана сети, вы сразу заметите, какие участки имеют не сети избыточности и т.д. Другими словами, топология L3 (а избыточность также) является такой же важной как физическом на избыточность уровне.
Заводите, кто же не дает, то. В куча моем хардкода и костылей, то-есть на другую без сеть серьезного допиливания не перенести. Основная том в суть, что по диапазону управляющего VLAN скрипт пробегает который строит L2 структуру сети на маков основании на портах (скрипту только надо маки задать ядра сети, чтоб строил от дальше), них строим дерево связей на этом вгружаем и основании в систему, самая сложная часть по выше ссылке, остальное базовые умения заббикса ну и оборудования знание в своей сети. Мне самому инструмент бы хотелось, чтоб прийти в любую сеть, местные где админы пролюбили схему сети, запустить тупо скрипт, пойти пить кофе и минут n через получить карту логических связей в виде графическом, а не сидеть несколько дней(недель) с подымать и инженером историю сварок, но к сожалению я такого пока инструмента не нашел, а мой не портируем на другие оборудование и сети без серьезной доработки. Упомянутое ниже мной решение от IBM отчасти позволит задачу решить. Да и не только у IBM в принципе такие есть решения (на вскидку, EMS Smarts, например, из сорсной опен области уже с ходу не назову там). Но ничего всегда будут нюансы.

Например, тупой неуправляемый хаб у большинства алгоритмов автоопределения вызывает топологии появление на схеме full-mesh из него в подключенных девайсов (мы их «ежами» прозвали, ибо одной). С похоже стороны такого в сети быть не другой, с должно — я знаю крупную компанию, где было такое в регионах. Глобальная карта их сети очень выглядела смешно.
Второй куда более нюанс серьезный работы подобных автоматизированных систем — таблицы опрос маршрутизации и ARP кэша. При размерах больших оных можно случайно завалить железку саму, если это делается по SNMP. ура на Cisco падает, проверяли.

Источник

Логическая схема сети l2 Логическая схема сети l2 Логическая схема сети l2 Логическая схема сети l2 Логическая схема сети l2 Логическая схема сети l2 Логическая схема сети l2

Изучаем далее:



Рисунки для вязания шапочек спицами

Металлические выдвижными ящиками своими руками5

Вкусняшки своими руками в домашних условиях

Как сделать колено на глушитель

Как сделать обрешетку под вагонку в парилке